首页 > PHP > osx10.10.2升级后php验证码无法使用解决办法
2015
02-15

osx10.10.2升级后php验证码无法使用解决办法

参考页面

http://yangjunwei.com/a/1570.html


这里讲了怎么修复,但是我们不太会在mac下编译php,难道要重新下载一个php来编译? 这个mac新手们都不明白的,怎么办呢

有集成解决办法

  1.  http://www.fieryrain.com/blog/mac_php_gd

    这个需要增加一个homebrew的方法 比较方便


  2. http://php-osx.liip.ch/

    简单的几行命令行代码即可搞定


homebrew 的安装


有中文版  http://brew.sh/index_zh-cn.html

10.5以上可以用这个

ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/install)"
直接使用brew install php54,结果报错,查了下资料,原来,需要:

brew tap josegonzalez/homebrew-php
brew tap homebrew/dupes 
brew install php54 --with-mysql --with-intl --with-fpm --without-apache


最后编辑日期:
作者:hainuo
hainuo
这个作者貌似有点懒,什么都没有留下。
https://shenghuo.alipay.com/transfer/aaCollect/pay.htm?id=18656668&sign=1e0c1245ffd24ee46f648ea278825f49
捐 赠如果您觉得这篇文章有用处,请支持作者!鼓励作者写出更好更多的文章!
php, mac, osx